This board has been archived, no new registrations are allowed. Please come join us on our discord!

Order template timeout

Can't figure out how to get a specific feature working? Ask for help here.
magnetar
Registered User
Posts: 8
Joined: Wed Jan 03, 2018 8:52 am

Order template timeout

Postby magnetar » Fri Jan 05, 2018 7:22 am

Hello,

I have been trading for a few days and have encountered this problem on a number of occasions:

It appears that a bot will try to execute a trade (it may succeed or fail to do so) and I will then receive a notification saying 'Order template xxxx has hit the timeout, the open order will be cancelled'.

I assume it is doing this as it has attempted to execute a trade and it believes it has failed.

In the most recent case, I have been using Alice Intellibot on WEX. The bot executed a SELL trade and did so successfully (checking my WEX account), however, the bot thinks it failed to do so. I then constantly received three messages on loop:

'Sending cancel order template...';
'Order template cancel failed';
Order template xxxx has hit the timeout, the open order will be cancelled'.

The bot has not recorded a successful SELL trade and this pattern continues until I restart the server and change the bot position to SOLD.

This behaviour was also happening with my on custom trade bots, however, I don't believe the trades were successful in those cases.

Could you offer any suggestions regarding this as a full restart of the server each time I catch it doing this is not helpful.

Thanks.

magnetar
Registered User
Posts: 8
Joined: Wed Jan 03, 2018 8:52 am

Re: Order template timeout

Postby magnetar » Fri Jan 05, 2018 10:49 am

Just had the same problem happen again, this time with HitBtc exchange. A sell trade was completed by the exchange but not recognised by the bot.

magnetar
Registered User
Posts: 8
Joined: Wed Jan 03, 2018 8:52 am

Re: Order template timeout

Postby magnetar » Fri Jan 12, 2018 4:25 am

Anyone??

It's been a constant problem for a week now and I have moved no closer to solving it.

Stephen suggested via email to use the Google DNS servers which I am doing, however, this has not made an impact.

As I am currently located in China, I decided to attempt to run the server of a European VPS, however, I have encountered a multitude of unresolved problems with getting this running on Linux (this forum post: viewtopic.php?f=9&t=1643&p=7559#p7559 )

Can anyone please help?


Return to “Help and Support”

Who is online

Users browsing this forum: No registered users and 8 guests