This board has been archived, no new registrations are allowed. Please come join us on our discord!

Massive latency

Can't figure out how to get a specific feature working? Ask for help here.
chris1
Registered User
Posts: 12
Joined: Sun Oct 04, 2015 3:54 pm

Massive latency

Postby chris1 » Sun Dec 03, 2017 7:33 pm

I'm getting 30-60 second delays in the marketview and 4 minutes on the bot indicator charts. My bots are responding according to the delay, and so of course they go to buy but get a VERY different result than expected.

AWS EC2 c5.2xlarge (8core 16gb ram, 2.5gigabit connection)
Ubuntu 16.04
Haasbot advanced license

Marketview latency:
I am using bitstamp, and I put up the haas marketview on one window and bitstamp tradeview on the other. The latency varies, but what I see is a change on the bitstamp tradeview, and no action on the haas marketview for ~30 seconds.. then all the actions in the last 30 seconds happen very quickly and it is up to date, then nothing again for 30-60 seconds.

bot indicators
Using DEMA I look at the indicator candlestick chart and the most current 4 sticks are always missing. Further, sticks are timestamped 4 minutes after their timestamp on the bitstamp tradeview, so not only is it 4 minutes delayed, it thinks it is current. I have watched buy/sale moves happen promptly when the indicator shows it crossing a threshold, and a buy go out, but of course the price is very different as it is 4 minutes late. So the bot is actually making decisions on delayed data (ie not a display issue)

I have sync'ed my hw clock with system clock and both show the correct time. Haas also displays the correct time in the website. How can I troubleshoot this? The latency makes it un-tradable.

DanialJ
Community Ambassador
Posts: 18
Joined: Fri Jul 21, 2017 2:00 pm

Re: Massive latency

Postby DanialJ » Wed Dec 06, 2017 3:58 pm

Just taking a shot in the dark, can you test the latency between your AWS instance and Bitstamp?
Get in touch with us at our Telegram:

https://t.me/haasonlineofficial - Main Discussion Channel

https://t.me/haasonlinesupport - Main Support Channel

raminsprung
Paid Subscriber
Posts: 2
Joined: Tue Jan 27, 2015 12:27 am

Re: Massive latency

Postby raminsprung » Sun Feb 04, 2018 3:55 pm

same issue here, have u managed to solve the problem?


Return to “Help and Support”

Who is online

Users browsing this forum: No registered users and 2 guests